Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 16, 2026 - 22:00 EDT
Scheduled
Pitt Digital will perform network maintenance between 10 and 11 p.m. on Monday, March 16. During this window, customers may experience brief interruptions to internet connectivity, Wi-Fi, and wired network service — generally lasting up to five minutes. GlobalProtect VPN connections may briefly disconnect but will automatically reconnect.
Longer interruptions of up to 15 minutes may occur in the following buildings:
• Allen Hall • Falk School • Gardner Steel Conference Center • K. Leroy Irvis Hall • Nordenberg Hall • O'Hara Student Center • Old Engineering Hall • Panther Hall • Soldiers and Sailors Memorial Hall • Space Research Coordination Center • Sutherland Hall • Thackeray Hall • Thaw Hall • University Club • Van de Graaff Building
MyResNet is not affected by this maintenance.
Pitt Digital will monitor the process and post updates to https://status.pitt.edu if there are any significant changes or delays.
Please submit a ticket to the Technology Help Desk at https://pi.tt/helprequest or call +1-412-624-HELP (4357) if you experience any issues or have questions related to this maintenance.
Posted Mar 16, 2026 - 16:51 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi) and Network, Hosting, and Storage (PittNet VPN (GlobalProtect)).