Vendor Issue Affecting Concur Travel & Expense Service

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their issue affecting Concur Travel & Expense and restored full service. Pitt Digital continues to closely monitor affected services to ensure continued reliability and stability.
Posted Mar 30, 2026 - 16:17 EDT

Investigating

Pitt Digital is aware of a vendor issue that is affecting the Concur Travel & Expense service. The issue, which affects customers beyond the University of Pittsburgh, is causing slowness in the expense report module.

The vendor is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Mar 30, 2026 - 13:03 EDT
This incident affected: Human Resources and Financial Systems (Concur Travel & Expense).