Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2026 - 23:00 EDT
Scheduled
Pitt Digital will conduct network maintenance that will result in rolling interruptions to PittNet Wi-Fi and wired service for up to 15 minutes in all locations on the Pittsburgh campus on Saturday, March 21, at 11 p.m. until Sunday, March 22, at 7 a.m.
This maintenance is required by our vendor to address an issue that has been intermittently impacting connectivity on the Pittsburgh campus. Although we had planned to complete this work in May, our vendor has required us to proceed this weekend. MyResNet Wi-Fi service will remain available during both maintenance periods.
Pitt Digital will be monitoring the maintenance periods, and in the event of any significant changes or delays, updates will be posted to status.pitt.edu. These maintenance periods are part of our continuous efforts to modernize the campus network and ensure security, stability, and reliability.
Please submit a ticket to the Technology Help Desk at digital.pitt.edu/help or call +1-412-624-HELP (4357) if you experience any issues or have questions related to these maintenance periods. This effort is being led by Lou Passarello, Pitt Digital’s director of operations.
Posted Mar 20, 2026 - 08:34 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).