Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2026 - 19:00 EDT
Scheduled
Pitt Digital will conduct network maintenance during three evening windows taking place May 6–9. The buildings and services listed below may experience interruptions to PittNet Wi-Fi, wired connectivity, telephony, and other network services — including internet access to cloud providers and external resources, and remote access via GlobalProtect VPN — during each window.
Friday, May 8, at 7 p.m. through 1 a.m. on Saturday, May 9
Impacted services:
• MyResNet connectivity — Pittsburgh campus • Posvar Hall — Integrated Security Department services • Pymatuning Lab of Ecology — network • Regional campuses — redundant connectivity • School of Dental Medicine — guest network • Student Health Services — Integrated Security Department services • University Club — guest network • Wireless PITT-MDA (IoT) network
Sunday, May 10, at 7 p.m. through midnight
• Internet connectivity for the Pittsburgh and regional campuses will experience brief disruptions, affecting access to cloud providers, external websites, and remote services.
Pitt Digital scheduled these windows during the end of term to minimize impact on daily operations. The team will monitor all maintenance and post updates to status.pitt.edu if significant changes or delays occur.
If any of these windows conflict with a critical activity in your area, or if you experience issues or have questions, please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357).
Posted May 01, 2026 - 15:00 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (MyResNet (Boldyn Residential Wi-Fi), PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi) and Communication and Collaboration (Voice and Data Services (Telephony)).