Vendor Issues Affecting PowerForm Access in DocuSign

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms full resolution of the Power Forms access issue in DocuSign.
Posted May 13, 2026 - 10:45 EDT

Monitoring

DocuSign has implemented a fix and full service has been restored. Pitt Digital continues to monitor the service for stability.
Posted May 12, 2026 - 16:12 EDT

Investigating

DocuSign is investigating an issue that may prevent some users from accessing PowerForms. As a workaround, PowerForm templates may be sent via the Templates tab. Please reach out to the PowerForm owner to send an envelope manually if it is necessary to sign a PowerForm.

Pitt Digital is monitoring the situation and will post updates as DocuSign provides them.
Posted May 12, 2026 - 16:01 EDT
This incident affected: Administrative and Business Systems (DocuSign).