Service Provider Issue Affecting Box (pitt.box.com)
Incident Report for Pitt IT Systems Status
Resolved
Box has resolved the issue and restored full service.
Posted Apr 01, 2021 - 08:48 EDT
Monitoring
Box has taken steps to address the issue that affected access to pitt.box.com earlier this morning and reports that services have begun to recover. Pitt IT continues to monitor the service and will post additional updates to status.pitt.edu.
Posted Apr 01, 2021 - 08:36 EDT
Investigating
Box is experiencing an issue with its service that is affecting access to pitt.box.com. Users may be unable to access content after logging in to the service, or they may be unable to log in entirely.

Box is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Apr 01, 2021 - 06:12 EDT
This incident affected: Box (pitt.box.com) (Box Content API, Box Uploads/Downloads, Box Collaboration, Box Box Website, Box Box Sync, Box Box Drive).