Service Provider Issue Causing Delay in Delivery of Pitt Email Attachments
Incident Report for Pitt IT Systems Status
Resolved
Microsoft has resolved the issue with its Office 365 service that caused delays in the delivery of attachments received through Pitt Email yesterday. Full service has been restored.

Please contact the 24/7 Technology Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Dec 07, 2018 - 10:11 EST
Investigating
Microsoft is experiencing an issue with its Office 365 service that is causing a delay in the delivery of attachments received through Pitt Email. Microsoft is aware of the issue and working to restore full service as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 Technology Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Dec 06, 2018 - 14:28 EST
This incident affected: Email (Pitt Email and Calendar, Advanced Threat Protection).