The commercial power provider has resolved their issue and restored power. Network service has also been restored to all affected locations.
Posted Mar 30, 2026 - 15:10 EDT
Investigating
A commercial power provider serving the University is experiencing an issue that has disrupted power to multiple buildings on upper campus. As a result, PittNet wired, PittNet Wi-Fi, and MyResNet Wi-Fi services are currently affected in locations including, but not limited to:
• The Assembly (5051 Centre Ave.) • Bioscience Tower • Bioscience Tower 3 • Darragh Street Apartments • Falk • Lothrop Hall • Mervis Hall • Petersen Events Center • Scaife Hall • Victoria Hall
The vendor is working to resolve the issue and restore power. Network service will be restored as quickly as possible once power is available. Updates will be posted to status.pitt.edu.
Posted Mar 30, 2026 - 14:02 EDT
This incident affected: Wired and Wi-Fi Networks (MyResNet (Boldyn Residential Wi-Fi), PittNet Wired Network, PittNet Wi-Fi).